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 Xilinx ISEافضاس  اص ػشی ساٌّوبّبی ًشم اًذاصی ػشیغ ّبی ساٌّوبی ًلت ٍ ساُگفتبس دس

Design Suite َُافضاس  ثِ ثشسػی ًشمدس ایي ساٌّوب ثِ كَست ولی تجییي ؿذ.  افضاس ی وبس ثب ایي ًشم ًح

PlanAhead ت لافضاس ّوشاُ ثب ً پشداصین. ایي ًشم هیISE ً ت ؿذُ اػت. دس ایٌدب لثش ػیؼتن ؿوب

سا خَاّیذ آهَخت.  FPGAؿوب ثب اًدبم سًٍذی سٍی یه ثلَن ػبدُ سٍؿی ثشای عشاحی وبسا دس 

اػت هَسد   ISEی وِ هَسد اػتفبدُ  PlanAheadتَخِ داؿتِ ثبؿیذ دس ایي ساٌّوب تٌْب ثخـی اص 

 گیشد.  ثشسػی لشاس هی

ی لجل اص ایي ػشی سا هغبلؼِ ّبساٌّوب دػتِ اص افشادی وِثذیْی اػت گفتبس پیؾ سٍ ثشای آى 

لاػبت ثیـتش دس ایي عوؼت اٍ خَاّبى  آؿٌبیی اثتذایی داؿتِ  افضاس ًشمثب ایي  ًذ ٍ یب افشادی وِاُ وشد

 هفیذ خَاّذ ثَد. صهیٌِ ّؼتٌذ،



 

 

 : 1 فصل
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 I/Oّبی  پبیِ 3سیضی ٍ عشح   Floorplaningٍ  0ؿبهل دٍ ثخؾ آًبلیض عشاحی فللایي 

 پشداصین. ثبؿذ وِ دس اداهِ ثِ تَضیح ّش یه هی هی

   Floorplaningآوالیس طراحی ي  -2-1

 ؿَد: دس ایي ثخؾ ػِ ػولیبت ػوذُ اًدبم هی

 ُّبی آًبلیض ػبصی ٍ ظشفیت عشاحی لجل پیبد 

 ُّب ػبصی ؿٌبػبیی ٍیظگی پیبد 

 ُػبصی ًتبیح  پیبدFloorplaning 

 هشاحل صیش سا اًدبم خَاّین داد.ثشای عی سًٍذ فَق ثِ كَست لذم ثِ لذم 

 3ی مىابع دستگاٌ ي وًاحی ساعت مشاَذٌ -2-1-1

 PlanAhead Start > Xilinx Design Tools > ISE Design Suite 14.5 <دس اثتذا اص هؼیش

> PlanAhead ؿَد. هیثبص  0-3ای هـبثِ ؿىل  بص وٌیذ. ثب اًدبم ایي وبس پٌدشُافضاس فَق سا ث ًشم 

                                           
0 Design Analysis 

3 Planning 

2 Clock Region 
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‌PlanAheadی‌آغاز‌‌غفحٍ  (1-2)‌ضکل

اػتفبدُ وٌیذ. ػپغ دس  Open Projectی   ی خَد سا ثبص وٌیذ اص گضیٌِ ثشای ایٌىِ پشٍطُ

 سا اًتخبة ٍ ثبص وٌیذ. xise.ی هشثَعِ، فبیل  پَؿِ
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‌باز‌کردن‌فایل‌پريشٌ  (2-2)‌ضکل

گشدد. ًبم هَسد ًظش سا  اص ؿوب دسخَاػت هی هیًب ISEدس هشحلِ ثؼذ ثشای ٍاسد وشدى پشٍطُ 

 ذ وٌیذ.ٍاسد ٍ تبیی

 

‌PlanAheadتعییه‌وام‌پريشٌ‌در‌  (3-2)‌ضکل

 ؿَد. هیی اكلی ثِ ؿىل صیش ثبص  دس ًْبیت پٌدشُ



 PlanAheadفلل دٍم:                                                      ISEافضاس  اػتفبدُ اص ًشمساٌّوبی 

 

 

06 Copyright © 2013 ICEEP, University of Tehran                                                            

 

 

‌PlanAheadی‌‌پىجرٌ  (4-2)‌ضکل

ای ثِ ًبم هٌبثغ داسد ثِ ثخؾ هشثَعِ سفتِ ٍ  پٌدشُ PlanAheadی  ثخؾ اكلی اص پٌدشُ

 لشاس داسد. 0ّب ی هحذٍدیت پشٍطُ دس صیش ؿبخِ  ucf. هغوئي ؿَیذ فبیل

 

‌مىابع‌ی‌پىجرٌ  (5-2)‌ضکل

                                           
0 Constraints 
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 Runٍ دس ًْبیت  Run Sythesis  اثتذا گضیٌِ Flow Nevigatorی  ی ثؼذ اص پٌدشُ دس هشحلِ

Implementation ُی  ی ثبص ؿذُ گضیٌِ سا ثضًیذ. ػپغ دس پٌدشOpen Implemented Design  سا

  ثضًیذ

 

‌باز‌کردن‌دستگاٌ  (6-2)‌ضکل

 ؿَد. هیپغ اص اًدبم ػولیبت فَق دػتگبُ ثِ كَست ؿىل صیش ًـبى دادُ  
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‌ومایص‌دستگاٌ  (7-2)‌ضکل

ّبی  ٍ یب وـیذى هؼغیل 0ثضسگٌوبیی ی وشدى سٍی دػتگبُ ٍ اًتخبة گضیٌِثب ولیه ساػت 

 تَاًیذ هٌبثغ آى سا هـبّذُ ًوبییذ. هیسٍی دػتگبُ ثِ كَست خضئی  وَچه

 

‌مىابع‌دستگاٌ  (8-2)‌ضکل

ا ّن هـبّذُ وٌیذ. ثشای ایي سبػت ی دػتگبُ ًَاحی ػ اًیذ سٍی پٌدشُتَ هیچٌیي ؿوب  ّن

                                           
0 Zoom 
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هشثَط ثِ ًَاحی ػبػت سا ثبص وشدُ، ثب اًتخبة ّش  ی پٌدشُ Window > Clock Regionوبس اص عشیك 

 ؿَد. هیسٍی دػتگبُ ًـبى دادُ  ،هشثَط ثِ آى ی وذام اص ًَاحی هَخَد دس لیؼت ًبحیِ

 

‌ساعت‌ی‌اوتخاب‌واحیٍ  (9-2)‌ضکل

 یبثیذ. هیی ّش ثخؾ دػت ّب ثِ ٍیظگی Propertiesی  ثب اػتفبدُ اص پٌدشُ

 تَاًیذ اص هحتَی هٌغمی ّش ثخؾ اعلاع حبكل وٌیذ. هی Statisticsی  ثب ٍاسد ؿذى ثِ ثشگِ

 

‌َا‌محتًی‌مىطقی‌بخص  (10-2)‌ضکل
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سا  IDELAYCTRLٍ  ّب BUFRخبی ّش وذام اص  Resourcesی  ثب ٍاسد ؿذى ثِ ثشگِ

 .وٌیذ هیهـبّذُ 

 

‌مطاَذٌ‌جای‌مىابع‌در‌دستگاٌ  (11-2)‌ضکل

 وٌیذ. هیثبًه ٍسٍدی ٍ خشٍخی آى ًبحیِ سا هـبّذُ  I/O Banksی  ثب اًتخبة ثشگِ

 

‌ی‌يريدی‌ي‌خريجیَا‌ی‌باوک‌مطاَذٌ  (12-2)‌ضکل

 پیي دػتگبُ سا هـبّذُ وٌیذ.ی  ًمـِتَاًیذعشح  هی Layout > I/O Planingاص هؼیش 



 PlanAheadفلل دٍم:                                                      ISEافضاس  اػتفبدُ اص ًشمساٌّوبی 

 

 

30 Copyright © 2013 ICEEP, University of Tehran                                                            

 

 

‌وقطٍ‌ی‌پیه  (13-2)‌ضکل

 گشدیذ.  ثِ حبلت لجل ثبص هی Windows > Default Layoutثب اًتخبة 

 تشریح ساختار سلسلٍ مراتبی -2-1-2

  Netlistی  سٍی ثشگِ Netlistی  فشم، دس پٌدشُ دس حبلت ًوبیؾ دػتگبُ ثِ كَست پیؾ

 ی ّب سفتِ ٍ ثب ساػت ولیه سٍی آى گضیٌِ سٍی ّش وذام اص ػجبست Primitiviesسفتِ ٍ دس ثخؾ 

Show Hierarrchy  ثِ كَست ػلؼلِ هشاتجی هـبّذُ سا اًتخبة وٌیذ. دس ًْبیت خبیگبُ آى ػجبست سا

 خَاّیذ وشد.
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‌جایگاٌ‌سلسلٍ‌مراتبی  (14-2)‌ضکل

 ومایص مشخصات مىابع طراحی -2-1-3

 < Flow Nevigator > Implementatinثشای هـبّذُ هیضاى اػتفبدُ اص هٌبثغ، هؼیش 

Implemented Design > Report Utilization  سا ثشٍیذ. ثب ایي وبس هیضاى اػتفبدُ اص ّش هٌجغ ًـبى

 ُ خَاّذ ؿذ.داد

 

‌میسان‌استفادٌ‌از‌مىابع  (15-2)‌ضکل

الذام  Window > Physical Constraintsیبثی ثِ خضئیبت ثیـتش دس هَسد هٌبثغ اص  ثشای دػت
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ثشٍیذ ٍ  Statisticsی  سٍی ثشگِ Propertiesی  ولیه وٌیذ ٍ دس پٌدشُ Rootوٌیذ. سٍی ػجبست 

 لیؼت هٌبثغ سا ثِ كَست خضئی ثشسػی وٌیذ.

DRCاجرای  -2-1-4
1 

Xilinx  ِیه ثبس ػبصی پیبدُوٌذ لجل اص  هیثِ عشاحبى تَكی ،DRC  سا اخشا وٌٌذ تب هؼبیل

پٌدشُ هشثَعِ سا  Tools > Report DRCهؼیش  اص ثشسػی ؿَد. ثشای ایي وبس ػبصی پیبدُهؼوَل دس 

 ثبص ًوَدُ ٍ تبییذ سا ثضًیذ.

 

                                           
0 Design Rule Check 
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‌DRCی‌اجرای‌‌پىجرٌ  (16-2)‌ضکل

 ؿَد. هیًتبیح ًـبى دادُ  Workspaceثب اخشای ایي ثخؾ دس ثخؾ 
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‌DRCوتایج‌اجرای‌  (17-2)‌ضکل

 آوالیس زماوی -2-1-5

ّبی صهبًی هَسد ثشسػی لشاس  ػبصی ثْتش اػت عشاحی اص ًظش اسضبی هحذٍدیت لجل اص پیبدُ

ٍخَد  FPGAافضاس لشاس گشفتِ ثش سٍی  وِ عشاح اص توبم تبخیشّبی ٍالؼی وِ دس ػخت گیشد تب ایي

 آگبّی یبثذ. ،داسد

 0وٌٌذُ هحذٍدیت صهبًی ثِ كَست دػتی ایدبد ًىشدین خوغ ucfس فبیل اص آًدب وِ هب د

آهبدُ  ی هوىي اػت ثؼضی اص اهىبًبت ایي لؼوت ثشای آى لبثل اػتفبدُ ًجبؿذ. ثٌبثشایي اص یه پشٍطُ

وٌین. ثشای ایي وبس دس كفحِ آػبصیي  هیایدبد ؿذُ اػت اػتفبدُ  PlanAheadوِ ّوشاُ ًلت 

PlanAhead  ثِ خبی اػتفبدُ اص آیىَىOpen Project  اص آیىَىOpen Example Project ُی  پشٍط

CPU(Synthesized)  سا ثبص وٌیذ ٍ چَى پشٍطُ لبثل ٍیشایؾ ًیؼت آى سا ثب ًبم دلخَاُ دس هحل

                                           
 ذُ خَاّذ آهذ.ی ایدبد ایي هحذٍدیت دس ساٌّوبّبی آیٌ آهَصؽ ًحَُ 0
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 هٌبػجی رخیشُ وٌیذ. 

ایي  سا ثضًیذ. پغ اص Implementationی  گضیٌِ Flow Nevigarorی ثبص ؿذُ اص  دس پٌدشُ

 ؿَد. هشحلِ دػتگبُ ثِ كَست صیش ثِ ؿوب ًـبى دادُ هی

 

‌CPUومایص‌دستگاٌ‌  (18-2)‌ضکل

 Flow Nvegatorسا ثضًیذ ٍ یب اص  Tools > Timing > Run TRCEدس ایي حبلت هؼیش 

 ی صیش ثبص خَاّذ ؿذ. سا اًتخبة وٌیذ. دس اداهِ پٌدشُ Run TRCEی  گضیٌِ
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‌TRCEاجرای‌  (19-2)‌ضکل

سا  tsi–وٌٌذ. اص ثیي آًْب  هیگضاسؽ سا ثِ ؿىل خبكی تَلیذ ی هَخَد ّش وذام ّب اص گضیٌِ

ؿَد اص هیبى چٌذ هحذٍدیت صهبًی وذام یه ًؼجت ثِ ثمیِ دس  هیاًتخبة وٌیذ وِ دس آى هـخق 

 اٍلَیت اػت.

ؿَد وِ هؼیشّبی هختلف ٍ هیضاى  هیدس پبییي ثبص  Timingی  پٌدشُ TRCEپغ اص اخشای 
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 بى دادُ ؿذُ اػت.تبخیش ٍ ػبیش خضئیبت ّش یه ًـ

 

‌مطخػات‌مسیرَای‌مختلف  (20-2)‌ضکل

 ثِ دلخَاُ یىی اص هؼیشّب سا اًتخبة ٍ خضئیبت ثیـتشی اص آى سا ثشسػی وٌیذ.

 

‌جسئیات‌مسیر  (21-2)‌ضکل

سا اًتخبة وٌیذ ٍ یب اص  Timing Constraintsی  گضیٌِ Windowی  دس ایي حبلت اص پٌدشُ

Flow Nvegator  سٍیEdit Timng Constraints ُای ثِ ؿىل صیش ًـبى دادُ خَاّذ  ثشٍیذ. پٌدش

 ؿذ.
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 Timing Constraints (22-2)‌ضکل

سا ثبص ًوَدُ ٍ  TS_sysClkهحشٍدیت  Clk period > Timespec periodاص عشیك هؼیش 

 تغییش دّیذ. 00ًبًَ ثبًیِ ثِ  01همذاس آى سا اص 

 

‌TS_sysClkمسیر‌محذيدیت‌  (23-2)‌ضکل
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‌يیرایص‌محذيدیت  (24-2)‌ضکل

دس ثؼضی هَاسد لاصم اػت تب هحذٍدیت خذیذ تؼشیف ؿَد ثشای ایي وبس سٍی آیىَى ثِ 

 ولیه وٌیذ تب پٌدشُ هشثَص ثِ تؼشیف هخذٍدیت ثبص ؿَد. صیشؿىل 

 

‌آیکًن‌تعریف‌محذيدیت  (25-2)‌ضکل
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‌ی‌تعریف‌محذيدیت‌پىجرٌ  (26-2)‌ضکل

 دس ایي پٌدشُ هحذٍدیت خذیذ سا تؼشیف ٍ تبییذ وٌیذ.

تَاًیذ آثبس تغییشات  هیسا دٍثبسُ اخشا وٌیذ. دس تْبیت  TRCE ثؼذ اص ّش گًَِ ٍیشایـی ثبیذ

 خَد سا هـبّذُ وٌیذ.

 افسار تشریح سخت -2-1-6

ؼی لافضاس ٍا اؿبسُ ؿذ، ّش وذام هؼیشی اص ػخت ّب یی وِ دس ثخؾ لجل ثِ تبخیش آىّب هؼیش

سا  Schematicسٍی آى ولیه ساػت وشدُ ٍ ػجبست  ّب ی خبیگبُ ایي هؼیش هذاس ّؼتٌذ. ثشای هـبّذُ
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 ثشگضیٌیذ.

 

‌ضماتیک‌مسیر  (27-2)‌ضکل

سا اًتخبة وٌیذ. دس  Select Primitive Parentsی ؿوبتیه ولیه ساػت وشدُ ٍ  سٍی پٌدشُ

ؿَد.  هیػبختبس ػلؼلِ هشاتجی ًوبیؾ دادُ  F6ؿَد. ثب صدى  هیچٌذ ٍاحذ اًتخبة  Netlistی  پٌدشُ

 اًتخبة ؿذُ اًذ. Netlistّبی اًتخبة ؿذُ دس  دس ایي ًَع ًوبیؾ ّن ثلَن

 

‌ی‌اوتخاب‌ضذٌ‌در‌ساختار‌سلسلٍ‌مراتبیَا‌بلًک  (28-2)‌ضکل
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دس ًْبیت سٍی ًوبیؾ دػتگبُ آهذُ ٍ یىی اص هؼیشّب سا اًتخبة وٌیذ. ایي هؼیش سٍی دػتگبُ ًیض 

 ًوبیؾ دادُ خَاّذ ؿذ.

 

‌ومایص‌مسیرَا‌ريی‌دستگاٌ  (29-2)‌ضکل

 بررسی اتصالات -2-1-7

 I/Oی اتلبلات  دس ایي ثخؾ ثِ ثشسػی اتلبلات دس دػتگبُ خَاّین پشداخت. ثشای هـبّذُ

 ثِ ؿىل صیش سا ثشگضیٌیذ. ی گضیٌِ

 

(30-2)‌ضکل I/Oاوتخاب‌گسیىٍ‌مطاَذٌ‌اتػالات‌ 
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‌I/Oومایص‌اتػلات‌   (31-2)‌ضکل

تَاًیذ اًتخبة وٌیذ ٍ ثب ولیه ساػت وشدى ٍ  هیسا  ّب ّش وذام اص ؿبخِ Netlistی  دس پٌدشُ

 اتلبلات هشثَط ثِ آى سا سٍی دػتگبُ هـبّذُ وٌیذ. Show Conectivityی  اًتخبة گضیٌِ

 

‌َای‌مختلف‌اتػالات‌بخص  (32-2)‌ضکل

 َای جایابی استفادٌ از محذيیت -2-1-8

دس ایي ثخؾ ثب عشص یبفتي ٍ پبن وشدى خبیبثی وِ تَػظ ػولیبت هؼیشیبثی ٍ خبیبثی 

 ؿَیذ. هیگیشد آَؿٌب  هیكَست 
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 ٍاسد ؿَیذ ٍ ًَع ثلَن سا اًتخبة وٌیذ. Edit > Findثشای یبفتي یه ثلَن اص 

 

‌اوتخاب‌وًع‌بلًک  (33-2)‌ضکل

 ػپغ دس پبییي كفحِ ّش ثلَن سا اًتخبة ٍ خبی آى دس دػتگبُ سا هـبّذُ وٌیذ.

 

‌Block RAMاوتخاب‌بلًک‌  (34-2)‌ضکل

بد ؿذُ اػت سا پبن وٌیذ ثشای اید ISEّبی خبیبثی وِ تَػظ  تَاًیذ هحذٍدیت هیحبل ؿوب 
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 Instanceی  گضیٌِ ٍاسد ؿَیذ. Tools > Floorplaning > Clear Placementایي وبس اص عشیك 

Placement ِی ثؼذ ثشٍیذ. سا اًتخبة ٍ ثِ هشحل 

 

‌Clear Placement‌(1)ی‌‌پىجرٌ  (35-2)‌ضکل

 سا اًتخبة ٍ ثِ ثؼذی ثشٍیذ. Unplace all instancesػجبست 
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‌Clear Placement‌(2)ی‌‌پىجرٌ  (36-2)‌ضکل

 سا ثضًیذ ٍ ثِ ثؼذی ثشٍیذ. Defaultػجبست 
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‌Clear Placement‌(3)ی‌‌پىجرٌ  (37-2)‌ضکل

 سا اًتخبة ٍ ثِ ثؼذی ثشٍیذ. Keep 12 fixed instancesگضیٌِ ی 
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‌Clear Placement‌(4)ی‌‌پىجرٌ  (38-2)‌ضکل

 .ی اتوبم سا ثضًیذ پغ اص ثشسػی خلاكِ گضیٌِ
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‌Clear Placement‌(5)ی‌‌پىجرٌ  (39-2)‌ضکل

 آیذ. هیًْبیت ًتیدِ ثِ كَست صیش دسدس 

 

‌وتیجٍ‌پاک‌کردن‌جایابی  (40-2)‌ضکل
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I/O 1َای  ریسی پایٍ طرح -2-2
 

 دس ایي لؼوت ًحَُ اختلبف پبیِ ثِ دػتگبُ سا هَسد ثشسػی لشاس خَاّین داد.

 I/Oَای  ریسی پایٍ ی طرح ساخه پريشٌ -2-2-1

 ی هشثَط سا ثبص وٌیذ.  پٌدشُ File > New Projectدس اثتذا اص هؼیش 

 

‌(1شٌ)‌ساخت‌پري  (41-2)‌ضکل

 ی ثؼذی ًبم ٍ هؼیش پشٍطُ سا ٍاسد وٌیذ. ی ثؼذی سا اًتخبة وٌیذ.دس پٌدشُ گضیٌِ

                                           
0 I/O Pin Planing 
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‌(2شٌ)‌ساخت‌پري  (42-2)‌ضکل

 سا ثشگضیٌیذ. I/O Planing Projectػپغ ػجبست 
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‌(3شٌ)‌ساخت‌پري  (43-2)‌ضکل

 ثِ پشٍطُ اضبفِ وٌیذ. csvٍ یب   ucfتَاًیذ یه فبیل  هیی ثؼذی  دس هشحلِ
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‌(4شٌ)‌ساخت‌پري  (44-2)‌ضکل

 ایي دػتگبُ لبثل تغییش اػت.. الجتِ دػتگبُ هملذ سا اًتخبة وٌیذ ػپغ
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‌(5شٌ)‌ساخت‌پري  (45-2)‌ضکل

 ی اتوبم سا ثضًیذ. ی پشٍطُ گضیٌِ پغ اص ثشسػی خلاكِ
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‌(6شٌ)‌ساخت‌پري  (46-2)‌ضکل

 ؿَد. هیدس ًْبیت ؿوبی صیش هـبّذُ 

 

‌ضمای‌ايلیٍ‌پريشٌ  (47-2)‌ضکل
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 دستگاٌ I/Oمىابع  -2-2-2

ٍ ػبیش  ّب I/Oتَاًیذ  هی ّب  ًوبّبی هختلفی ٍخَد داسد وِ ثِ ووه آى PlanAheadدس 

 افضاس هشثَط ثِ عشاحی خَد سا هـبّذُ وٌیذ.  ػخت

ی  پشداصین. ثشای ایي وبس دس پٌدشُ هی I/Oی ّب دس ایي لؼوت ثِ ثشسػی ًوبیؾ خبیگبُ  ثبًه

Package Pins ی  بُ دس ثشگِسٍی یىی اص ثبًىْب ولیه وٌیذ ٍ خبی آى سا دس دػتگPackage  ُهـبّذ

 وٌیذ.

 

(48-2)‌ضکل I/Oی‌َا‌اوتخاب‌باوک 

هـبّذُ وٌیذ.  Dieثشٍیذ تب خبی ثبًه هٌتخت سا سٍی  Deviceی  ػپغ سٍی ثشگِ

ّبی هختلف دس فشآیٌذ تخلیق پبیِ ثؼیبس هفیذ خَاّذ ثَد. دس  ّب دس ثشگِ ی خبیگبُ ثبًه هـبّذُ

ی آى ثبًه، ّوشاُ ثب ّب ّب لیؼت توبم پبیِ ام اص ثبًهًیض ثب ثبص وشدى ّش وذ Package Pinsی  پٌدشُ
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 اعلاػبت خضئی ساخغ ثِ ّش پبیِ سا هـبّذُ خَاّیذ وشد.

 تعریف دستگاٌ سازگار -2-2-3

هوىي اػت ؿوب ثخَاّیذ دس ٌّگبم اًدبم پشٍطُ دػتگبُ ّذف خَد سا تغییش دّیذ. 

PlanAhead  ػتگبُ فؼلی سا تؼشیف ٍ دس صهبى ی ػبصگبس ثب دّب دّذ وِ دػتگبُ هیایي اهىبى سا ثِ ؿوب

یش ثذّیذ. الجتِ ایي اهىبى بی ػبصگبس تؼشیف ؿذُ تغیّ دػتگبُ ّذف سا ثِ یىی اص دػتگبُ هَسد ًیبص

 ٍخَد داسد.   Virtex-5، Virtex-6  ٍSpartan-6ی ّب تٌْب دس دػتگبُ

ایدبد وٌیذ تب دس كَست تغییش  ّب I/Oثشای فؼبل ػبصی ایي اهىبى ؿوب ثبیذ هحذٍدیتی دس 

اػتفبدُ وشدُ ایذ. ثشای ایي وبس هؼیش  ّب ی هـتشن دس آى دػتگبُّب دػتگبُ هغوئي ثبؿیذ وِ اص پبیِ

Tools > I/O Planing > Set Part Compatibility پغ ػجبست هَسد ًظش سا تیه سا ثشگضیٌیذ. ػ

 ثضًیذ.

 

‌اوتخاب‌دستگاٌ‌سازگار  (49-2)‌ضکل



 PlanAheadفلل دٍم:                                                      ISEافضاس  اػتفبدُ اص ًشمساٌّوبی 

 

 

.9 Copyright © 2013 ICEEP, University of Tehran                                                            

 

 ایجاد محذيدیت -2-2-4

َستی دػتی یه یب چٌذ پبیِ ٍ یب یه ثبًه سا غیش فؼبل وٌیذ ثشای ایي وبس كتَاًیذ ثِ  هیؿوب 

ساػت  Packageی  سٍی آى یب پٌدشُ Package Pinsی  ثب اًتخبة پبیِ ٍ یب ثبًه هشثَعِ اص پٌدشُ

 سا اًتخبة وٌیذ. Set prohibitولیه وشدُ ٍ ػجبست 

 

‌‌محذيدیتایجاد‌  (50-2)‌ضکل
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‌14وک‌ی‌غیر‌فعال‌کردن‌با‌وتیجٍ  (51-2)‌ضکل

 I/Oَای  بىذی پایٍ ایجاد ي پیکر -2-2-5

سا ثبص وشدُ ٍ ثب ساػت ولیه وشدى سٍی  I/O Portsی  پٌدشُ Window > I/O Portsاص هؼیش 

 سا ثضًیذ. Ports  Create I/Oآى ػجبست
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‌I/Oی‌تعریف‌‌پىجرٌ  (52-2)‌ضکل

ّبی تؼشیف ؿذُ I/Oخبة ٍ تبییذ وٌیذ. دسًْبیت لیؼت تّبی پٌدشُ سا هغبثك ؿىل اً گضیٌِ

 ؿَد. هی I/O ی ٍاسد پٌدشُ

 

(53-2)‌ضکل  ‌I/O Portsی‌پىجرٌ 

 Configure I/Oی ایدبد ؿذُ دٍثبسُ ساػت ولیه وشدُ ٍ ػجبستّب I/Oثشای پیىشثٌذی 

Ports  ی هَخَد دس آى ّب تَاًیذ گضیٌِ هیؿَد وِ  هیسا اًتخبة وٌیذ. ثب اًدبم ایي ػول پٌدشُ صیش ثبص

 سا تغییش دّیذ.
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‌َاI/Oی‌پیکربىذی‌‌پىجرٌ  (54-2)‌ضکل

 ای ایدبد ؿذُ سا اص ثیي ثجشیذ. توبم پَستِ Edit > Undoثب اًدبم 

 I/Oيارد کردن لیست  -2-2-6

یی وِ داسای لیؼت پبیِ ّؼتٌذ ثِ پشٍطُ اضبفِ وشد. ّب فبیلتَاى اًَاع  هی I/Oی  دس یه پشٍطُ

ٍاسد ایي  سا وٌٌذُ خوغ ی پشٍطُ csvخَاّین فبیل  هیاػت. دس ایٌدب  csvٍ یب  ucfفبیل  ّب فبیلایي 

ی ثبص  ولیه وشدُ ٍ دس پٌدشُ Import I/O Portsسٍی  Flow Nevigatorپشٍطُ وٌین ثشای ایي وبس دس 

 سا اًتخبة وٌیذ. وٌٌذُ خوغسا اًتخبة ٍ فبیل   ucfؿذُ فبیل 
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‌csv اوتخاب‌فایل‌  (55-2)‌ضکل

 ّبی فبیل اضبفِ ؿذُ سا هـبّذُ لیؼت پبیِ I/O Portsی  پغ اص اًدبم ایي ػول دس پٌدشُ

 خَاّیذ وشد.

 

‌کىىذٌ‌جمع‌یَا‌پایٍلیست‌  (56-2)‌ضکل

 I/Oی َا خارج ومًدن فایل تخصیص پایٍ -2-2-7

تَلیذ ؿَد.  VHDL  ٍVerilogٍ یب ثب فشهت  ucf ،csvتَاًذ ثب پؼًَذ  هیفبیل تخلیق پبیِ 

ثشٍیذ. دس ایي حبلت دس  Export I/O Portsی  سٍی گضیٌِ Flow Nevigatorثشای تَلیذ ایي فبیل دس 

 ی ثبص ؿذُ ًَع فبیل ٍ ًبم ٍ هؼیش هشثَط ثِ رخیشُ سا اًتخبة ٍ. تبییذ وٌیذ. پٌدشُ
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‌یع‌پایٍػتًلیذ‌فایل‌تخ  (57-2)‌ضکل

 I/Oَای  جایابی اتًماتیک پایٍ -2-2-8

PlanAhead ُوٌذ. یىی اص  هیخبیبثی ثِ وبسثش هؼشفی  اًدبم ػولیبت ی گًَبگًَی ثشایّب سا

ػولیبت خبیبثی سا ثب ٍفبداس هبًذى ثِ لَاًیي  افضاس ًشمخبیبثی اتَهبتیه اػت وِ دس آى خَد  ّب ایي ساُ

ساػت ولیه  I/O Portsی  دّذ. ثشای اػتفبدُ اص ایي ًَع خبیبثی سٍی پٌدشُ هیاًدبم  I/Oی ّب ثبًه

ای هبًٌذ ؿىل صیش ثبص  ثب ایي وبس پٌدشُسا اًتخبة ویٌذ.  Auto-Place I/O Portsوشدُ ٍ ػجبست 

 ؿَد. هی
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‌(1جایابی‌اتًماتیک)‌ی‌پىجرٌ  (58-2)‌ضکل

 ِ اتوبم سا ثضًیذ.كشل خلاتی ثؼذی ثؼذ اص وٌ ثؼذی سا ثضًیذ. دس پٌدشُ  هیثذٍى ّیچ الذا
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‌(2ی‌جایابی‌اتًماتیک)‌پىجرٌ  (59-2)‌ضکل

 آیذ. هیثِ ؿىل صیش دس   I/O Portsّب دس  دس ًْبیت ػولیبت خبیبثی اًدبم گشفتِ ٍ لیؼت پبیِ

 

‌بعذ‌از‌جایابی‌َا‌لیست‌پایٍ  (60-2)‌ضکل

  DRCفعال ي غیر فعال  -2-2-9

PlanAhead  اهىبى چه وشدى دسػتی ػولیبت تخلیق پبیِ سا داسد. ثشای ایي وبس اص هٌَی
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Tools >Options   سا اًتخبة وشدُ ٍ دس ثشگِ یGeneral ،Automatically Enforce Legal I/O  سا

 تیه ثضًیذ.

 

‌پایٍکىترل‌درستی‌عملیات‌تخػیع‌  (61-2)‌ضکل

 I/Oَای  ی دیگر جایابی پایٍَا ريش -2-2-11

بی ّ اتَهبتیه سا سّب وشدُ ٍ ثِ گضیٌِثشای وٌتشل ثیـتش ػولیبت خبیبثی، هیتَاى خبیبثی 

 پشداصین: ّبهی دیگشی هشاخؼِ وٌیذ وِ دس اداهِ ثِ ثشسػی آى

 0خبیبثی پی دس پی
 

                                           
0 Sequentially 
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ثشٍیذ ٍ اًتخبثـبى وٌیذ ٍ ثب ساػت  I/O Portsی  پٌدشُ ثِ ،َع خبیبثی سٍی یه یب چٌذ پبیِثشای ایي ً

ی  سا اًتخبة وٌیذ.ػپغ سٍی پبیِ Place I/O Ports Sequentiallyی  ولیه وشدى سٍی آًْب گضیٌِ

سفتِ ٍ سٍی آى ولیه وٌیذ اگش چٌذ پبیِ سا اًتخبة وشدُ ایذ ایي  Packageی  هَسد ًظشتبى دس پٌدشُ

 یبثذ. هیػولیبت اًتخبة پبیِ تب تخلیق پبیِ ثِ آخشیي پبیِ اداهِ 

 

‌اختػاظ‌پایٍ‌ترتیبی  (62-2)‌ضکل

 ی ّب خبیبثی دس ثبًهI/O 

وٌین اهب دس هشحلِ ساػت  هیهبًٌذ حبلت لجل ػول  I/Oی ّب دس ثبًه ّب ثشای خبیبثی پبیِ

وٌین. دس  هیسا اًتخبة  Place I/O Ports in an I/O Bankی  پبیِ ثشای ایي لؼوت گضیٌِ ولیه سٍی

حشوت وشدُ تب ایٌىِ  Packageایي حبلت ثب تَخِ ثِ تؼذاد پبیِ هٌتخت چٌذ پبیِ ّوشاُ هَع سٍی 

آى ًـبى  ی خبی آى سا دس ثبًه هخلَكی تؼییي ًوبیین. دس ایي حبلت ثب سفتي سٍی ّش ثبًه ؿوبسُ

 ؿَد. هیی لبثل خبیبثی دس آى هـخق ّب ؿَد ٍ تؼذاد پبیِ هیادُ د
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 ِای خبیبثی ًبحی 

 Placeدس ایي حبلت ّن هبًٌذ حبلت لجل پبیِ سا اًتخبة ٍ ثب ساػت ولیه وشدى سٍی آى 

I/O Ports in an I/O Bank َآیذ تب  هییذ دیذ وِ هَع ثِ ؿىل ثِ ػلاٍُ دس اّسا اًتخبة وٌیذ. خ

 دس آى ثبؿذ سا تؼییذ وٌیذ. ّب خَاّیذ پبیِ هیِ و ؿوب ًبحیِ ای

 

‌تعییه‌پایٍ‌در‌واحیٍ  (63-2)‌ضکل

ی چبیبثی دس ثبًه یب ًبحیِ اگش ثخؾ اًتخبة ؿذُ داسای تؼذاد پبیِ ّب دس ّش وذام اص حبلت

دّذ وِ ثبًه یب ًبحیِ دیگشی سا  هی افضاس ثِ ؿوب اخبصُ ووتشی ًؼجت ثِ تؼذاد اًتخبة ؿذُ ثبؿذ، ًشم

 ی اضبفی اًتخبة وٌیذ.ّب پبیِثشای خبیبثی 

 DRCاجرای  -2-2-11

سا ثضًیذ یب اص   DRC، ،Tools > DRC Reportپغ اص اًدبم ػولیبت خبیبثی ثشای اخشای 
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Flow Nevigator ،DRC Report .سا اًتخبة وٌیذ 

 

(64-2)‌ضکل DRCاجرای‌ 

 ثشای گضاسؽ ًبم اًتخبة وشدُ ٍ تبییذ وٌیذ.

خِ ؿذیذ ثِ ایي هؼٌی اػت وِ خغبیی هَا No violations foundدس ًْبیت اگش ثب پیبم 

 ِ ثِ ؿوب ًـبى دادُ خَاّذ ؿذ.حَست خغبّب دس پبییي كفكٍخَد ًذاسد دس غیش ایي 
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 RTLحرکت بٍ سمت طراحی  -2-2-12

ثبؿذ.  RTLی  ی آغبصی ثشای ایدبد یه پشٍطُ غِتَاًذ ًم هی I/O Planingی  یه پشٍطُ

اًتمبل  RTLی  تَاى ًتبیح سا ثِ یه پشٍطُ ػولیبت خبیبثی اًدبم ؿذ، هی I/O Planingصهبًی وِ دس 

 File > Migrateرخیشُ ؿَد، سًٍذ  Verilogیب  VHDLداد. ثشای ایي وِ ًتیدِ ثِ كَست یه فبیل 

to RTL  سا عی وشدُ ٍ یب اصFlow Nevigator ،Migrate to RTL ُی ثبص  سا اًتخبة وٌیذ ٍ دس پٌدش

 ًوبییذ.ؿذُ هحل ٍ ًَع فبیل خشٍخی سا اًتخبة 

 

‌RTLحرکت‌بٍ‌سمت‌طراحی‌  (65-2)‌ضکل

 1آوالیس اختلال -2-2-13

PlanAhead ُی هختلف فشاّن وشدُ اػت. ثشای اػتفبدُ ّب اهىبى آًبلیض اختلالات سا دس دػتگب

سا  Flow Nevigator، Report Noiseسا عی وشدُ ٍ یب اص  Tools > Report Noiseاص ایي اهىبى سًٍذ 

SSNَع دػتگبُ آًبلیض دس ایي حبلت ثؼتِ ثِ ً  .اًتخبة وٌیذ
0ٍ یب  3

SSO گیشد. اًدبم هی 

                                           
0 Noise 

3 Simultaneous Switching Noise 
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  آًبلیضSSN 

 Spartan-6 ،Virtex-6،Virtex-7، Kintex™-7ٍ Artix™-7ی ّب ایي ًَع آًبلیض دس دػتگبُ

ی ّب وشدى ّوضهبى خشٍخی Switchهحبػجبتی سٍی خشاثی یه خشٍخی، ٌّگبم  ٍ ؿَد هیاًدبم 

 دّذ. هیدیگش اًدبم 

 ثِ ؿىل صیش اػت: SSNپٌدشُ ی آًبلیض 

 

(66-2)‌ضکل SSNآوالیس‌ 

ییذ وٌیذ.پغ اص اًدبم ایي ًبم ٍ ًَع فبیل خشٍخی سا اًتخبة ٍ تب Export to fileدس لؼوت 

 فحِ لبثل دػتیبثی اػت.كگضاسؽ ایي آًبلیض دس پبییي ػولیبت، 

 

‌SSNگسارش‌آوالیس‌  (67-2)‌ضکل

                                                                                                                            
0 Simultaneous Switching Output 
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  آًبلیضWASSO
0 

ی ّب ؿَد ٍ دس دػتگبُ هیبدُ اػتف 3ایي ًَع آًبلیض ثشای چه وشدى اػتجبس توبهیت ػلائن

Spartan-6 ،Virtex-6، Virtex-7  ، Kintex-7 ٍ  Artix-7ثِ آًبلیض تاعلاػبت، ووتشی ًؼج SSN  

ؿَد. دلت وٌیذ وِ ًَع ایي  هیاًدبم  SSNثشای اًدبم ایي آًبلیض سًٍذی هـبثِ  آًبلیض  دّذ. هیًـبى 

 ثبؿذ. هیآًبلیضّب ثؼتِ ثِ دػتگبُ 

                                           
0 Weighted Average Simultaneous Switching Output 

3 Signal Integrity 
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A 

Automatic اتَهبتیه، خَدوبس 

B 

Breakpoint  ِی اًفلبل ًمغ 

C 

Clock Region 
 ًبحیِ ی ػبػت

Constraint 
 هحذٍدیت

Core Generator 
    ی ّؼتِ تَلیذوٌٌذُ

D 

Debugging 
 صدایی اؿىبل

Design Analysis 
 آًبلیض عشاحی

Design Rule Check 
 ثشسػی لَاًیي عشاحی

Drag and Drop 
 وـیذى ٍ اًذاختي

Dynamic 
 پَیب

E 

F 

Full View دیذ وبهل 
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G 

Generate تَلیذ وشدى 

H 

Hardare Design Level افضاس عشاحی دس ػغح ػخت 

I 

I/O Pin Planing ّبی  سیضی پبیِ عشحI/O                                                                       

Information     اعلاػبت 

J 

K 

L 

M 

Manual 
                                                                                    دػتی

Marker 
 گزاس ًـبى

Math Functions 
 تَاثغ سیبضی

N 

Noise اختلال 
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O 

Objects اؿیب 

P 

Part Selection 
                                                                                                   اًتخبة ثخؾ

Planning 
                    سیضی عشح

Q 

R 

Restart   ُؿشٍع دٍثبس 

S 

Sequentially 
 پی دس پی

Signal Integrity 
                            توبهیت ػلائن

Simultaneous Switching Noise 
 صهبى اختلال ًبؿی اص تغییش ّن

Simultaneous Switching Output 
 صهبى خشٍخی تغییش ّن

Spreadsheet 
                                                                                           ی گؼتشدُ كفحِ

Static 
 ایؼتب

Sub-Module 
                                                                                           ٍاحذصیش 

Subtractor 
                                                                                            وٌٌذُ تفشیك
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T 

Tab 
 ثشگِ

Toolbar 
                                                                                       هٌَی اكلی

U 

V 

W 

Weighted Average Simultaneous Switching Output  صهبى خشٍخی تغییش ّنداس  هیبًگیي ٍصى 

X 

Y 

Z 

Zoom 
 ثضسگٌوبیی

                        


